EpicTable 1.1 is available now!

edited August 2013 in Announcements
EpicTable 1.1 is available now! All the details are in this post:

http://www.epictable.com/blog/announcements/epictable-1-1-released/. It was more work and more time than I expected, but it's a significant boost over 1.0 and sets up some of the new work really well. I'll talk more about the new work soon. You might just see a preview at Gen Con. If not, you'll get a preview via screencast.

Comments

  • Hey john ,



    First off i wanted to say congrats on the 1.1 release. My group have been waiting on this and cant wait for our game night this Friday. We have been running a game for a little over a year using Epictable , and just started a new game a few weeks ago "Space setting" and 1.1 will def open up some barriers that we may have had with that. My group of 4 is now 7 and we all appreciate what you've done here to make gaming possible with people from all over the world.



    I do have some questions tho, i'm not sure if this i intentional supposed to happen with the relese or not, But all of our map,hangouts, and character are gone. I get a error when opening epic table 1.1. I'm not sure if its something on my end or not. Considering we just started this game its not all that bad . I could put the stuff back in there , but one map would be a pain to recreate lol





    Ill attach the error so you can see it.

    Attached files image
  • So sorry about that. That's not to be expected. More like embarrassing. It looks like a problem loading a handout. I'm on a plane, but I can be of more help to you tonight. The good news is that your map is likely still okay. I'll research the handout issue tonight. Meanwhile, you can try two things to safeguard your work in the meantime.

    If you run Collect Diagnostics, it has the happy side effect of saving all your map and game definitions. So, do that first. You may recall that you can do that without starting ET (via the Windows start menu or from Explorer).

    Now, with that done:

    1. Create a new game. Add something like a map--just not a handout. Close ET and reopen. Should be fine.

    2. Now, add a handout, give it a second or two to save, close and reopen ET.

    If the handout is fine, this has something to do with old handouts. If not, it affects new ones too. Either way, it's probably a quick fix.



    One other thing, Rodney. I know you're looking for map tokens attached to or grouped with others--like for vehicles, ships, and mounts. That's coming, but it didn't make the 1.1 cut. Same goes with the initiative tracker (which, as you might guess, is larger in scope than grouping objects).



    Stay tuned.
  • hey John , Thank you for the info . I ran threw your steps and your right , I made a new game loaded a map, dice cup , token then saved. Closed . Opened just fine. I added a handout. It Error-ed when opening the second time so it seems all hangouts cause this at the moment.



    I understand about the grouping and Int. Tracker. We are able to work around it so no worries. With the smooth movement ET now has. It prob wont even hinder us.
  • I duplicated the same thing on the plane! I've put in a fix. It's a bit of a stop-gap measure, in that handouts still aren't functional, but it will allow you to load your game. It's 1.1.0.11, and if you simply re-download and install over top of what you've got, you'll be fine. I'll get a fix out for handouts soon.



    One other note that I neglected to mention in my 1.1 notes: dice rolls between 1.0 and 1.1 are incompatible. That's one I can't easily do much about.
  • That download page is http://www.epictable.com/download/ by the way.



    And give me a couple days on the dice roll incompatibility. I may have a trick up my sleeve...
  • Thank you again that did bring everything backup . I do have one more question tho and hopefully its a quick fix like the hangouts. The map i mentioned before was made of planets we created "im not sure why " but I used the text in epic table to label those planets. The Map is back up but the text is gone. The text boxes are still there when i outline it but no visible text. Is that recoverable as well ?
  • I'll look into it. Text objects, in particular rich text objects, underwent substantial change. I'll clarify the backwards compatibility situation too. I was over generalizing when I said 1.1 was backwards compatible with 1.0. I was really thinking about maps when I said that. I'll see how much I can make backwards compatible. When's your next game?
  • No problem if it is not able to be recovered. Would downloading 1.0 again bring them back up, so i can Screen shot it . Then putting 1.1 back on it again ? We Game on Friday's.
  • It depends on whether or not that tabletop was saved with a 1.1 view of the world and whether that left alone the things it wasn't able to convert from 1.0. Until I see the problem, I really can't say. However, if you don't have a lot invested in the 1.1 game yet, I'd load it up on 1.0 and see.
  • Solved the problem with 1.0 -> 1.1 dice rolls.

    I'm uploading ET 1.1.1.0 now, which takes care of that.

    Text fields are still mysterious.

    Need to look into it further.
  • This 1.1 update is a great news !



    I will test it as soon as possible ! :)
Sign In or Register to comment.